Partial Internet Outage in Centennial
Incident Report for Ting Internet
Resolved
This incident has been resolved.
Posted Jan 13, 2023 - 16:50 EST
Update
We are continuing to investigate this issue.
Posted Jan 12, 2023 - 11:27 EST
Investigating
We are currently investigating on the issue and working towards restoring the internet service to affected customers shortly, ETA will be provided soon..
Posted Jan 12, 2023 - 11:27 EST
This incident affected: Colorado (Centennial, CO).