Ting Internet - Angier, NC - Partial Outage

Incident Report for Ting Internet

Update

We are experiencing a service interruption in ANGIER NC caused by a third-party fiber strike. Our field teams are on-site and actively working on repairs. The current Estimated Time of Restoration (ETR) is 12:00 AM. We apologize for the inconvenience and will provide updates as new information becomes available.
Posted Feb 25, 2026 - 17:09 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 25, 2026 - 16:07 EST

Investigating

Ting Internet engineers are investigating reports of an outage impacting service for some customers in Angier, NC. We will post further information and next steps here as soon as it becomes available.
Posted Feb 25, 2026 - 14:52 EST
This incident affects: North Carolina (Angiers, NC).