eSIM activation issue

Incident Report for Ting Internet

Resolved

At this time, all eSIM activations are now working again.
Posted Oct 20, 2025 - 11:05 EDT

Monitoring

We continue to monitor the issue. If you are using an IOS device, please ensure that you have updated your device to the newest software version available as we have seen that correct the issue as well.
Posted Oct 20, 2025 - 10:40 EDT

Identified

We are currently investigating an issue preventing customers from activating new eSIMs for devices. We are working with our partners to investigate and work on a resolution. No ETA at this time.
Posted Oct 17, 2025 - 11:49 EDT
This incident affected: Customer Support.