Ting Internet - Centennial CO Outage

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Mar 12, 2025 - 09:14 EDT

Monitoring

This fix has been implemented and we are seeing full recovery of all offline services. If you are still seeing an impact, please attempt a power cycle of your equipment in-home (unplug from power, wait 10 seconds, then plug in again) and if the problem persists get in touch with our support team at 1-844-846-4994 so we can proceed with further individual diagnosis.
Posted Mar 11, 2025 - 21:28 EDT

Update

Ting techs are instating a solution to bypass the long-haul fiber strand that we have identified as the common factor in this outage. If this fix holds, service should be back online in short order. If not, we will continue to investigate. Next update within 30 minutes.
Posted Mar 11, 2025 - 21:06 EDT

Update

Ting techs are onsite at the field cabinet now and surveys / troubleshooting has begun to locate and confirm the problematic component.
Posted Mar 11, 2025 - 18:56 EDT

Update

This outage may affect residents along the 7500+ block of E Arapahoe Rd, and others on E Briarwood blvd, S Ulster Cir, S Uinta St, E Costilla Ave, E Davies Pl. This list is not exhaustive but if you are outside the general area it is unlikely you will notice an impact.
Posted Mar 11, 2025 - 18:18 EDT

Identified

We have identified an issue causing a service impact to approx 125 customers in Centennial CO. Field techs are at present en route to the affected field cabinet to determine the cause of the issue and affect repairs ASAP. We do not yet have an ETR but will provide one once techs have made their initial assessment.
Posted Mar 11, 2025 - 18:10 EDT
This incident affected: Colorado (Centennial, CO).