Ting Internet - Outage in Fuquay-Varina, NC.

Incident Report for Ting Internet

Monitoring

A fix has been implemented, and we are starting to see affected customers with their services restored. We will be monitoring the connections closely to ensure there are no further issues. Thank you for your patience.
Posted Jul 08, 2026 - 10:40 EDT

Investigating

We are investigating an issue impacting service for some of our Fuquay-Varina, NC customers. We will provide more information as it becomes available.
Posted Jul 08, 2026 - 10:02 EDT
This incident affects: North Carolina (Fuquay-Varina, NC).