Our field team is finishing the repairs and any remaining customers affected by this outage should see their service restored. Thank you for your patience.
Posted Jun 11, 2025 - 17:33 EDT
Update
We are still seeing a handful of customers affected by the outage. Our field crews are currently en route to address the remaining issues. Thank you for your patience as we work to get everyone back online as quickly as possible.
Posted Jun 11, 2025 - 09:38 EDT
Monitoring
A fix has been put in place. Please restart your equipment if you are offline. The equipment should now be online, and if, after a restart, you are not back online, please give us a phone call at 1-844-846-4994.
Posted Jun 11, 2025 - 01:37 EDT
Update
Ting Internet engineers are on site at the location of a fiber cut. Work is underway to replace the damaged sections of fiber and the current approximate ETA for service restoration is 12 AM EST. This is longer than expected initially. We apologize for the delay and will provide updates as work progresses. Thank you for your patience.
Posted Jun 10, 2025 - 17:52 EDT
Identified
Ting Internet engineers are on site at the location of a fiber cut. Site preparation is underway to replace the damaged sections of fiber and the current approximate ETA for service restoration is 8PM ET. We will provide updates as work progresses. Thank you for your patience.
Posted Jun 10, 2025 - 13:40 EDT
Investigating
We are seeing an outage affecting some customers in Fuquay Varina, NC. We are still investigating the cause and will have more updates as they come.
Posted Jun 10, 2025 - 12:26 EDT
This incident affected: North Carolina (Fuquay-Varina, NC).