Ting Internet - Outage in Charlottesville, VA Walker Square MDU's

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Jul 07, 2025 - 16:44 EDT

Investigating

We are currently investigating an issue affecting some of our customers in the Walker Square MDUs in the Charlottesville, VA market. We will share updates as more information becomes available.
Posted Jul 07, 2025 - 13:03 EDT
This incident affected: Virginia (Charlottesville, VA).