Ting Internet - Outage in Colorado Springs, CO

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Jun 25, 2026 - 11:02 EDT

Monitoring

The overnight maintenance has now been completed, and at this time we are seeing the majority of services fully restored.

If you are still experiencing issues, please reboot both your fiber modem and router. If the problem persists after rebooting, please contact us at 1-844-846-4994 so we can perform further troubleshooting on your individual service.
Posted Jun 25, 2026 - 08:56 EDT

Identified

The outage has been identified as being related to scheduled maintenance associated with ongoing road work in the area. The current estimated restoration time is 7:00 AM MST. We appreciate your patience and will provide further updates as they become available.
Posted Jun 25, 2026 - 04:15 EDT

Investigating

We are currently investigating a service outage impacting some customers in the Colorado Springs, CO market. Our team is working to identify the cause, and we will share updates as more information becomes available
Posted Jun 25, 2026 - 03:04 EDT
This incident affected: Colorado (Colorado Springs, CO).