Ting Internet - Holly Springs, NC - Emergency Maintenance

Incident Report for Ting Internet

Update

Splicing is continuing and we are seeing a volume of Ting customers back online. Work is ongoing and we expect to see full restoration within approximately 90 minutes.
Posted Aug 05, 2026 - 13:51 EDT

Update

The Town of Holly Springs reports splicing to restore service is underway and customers can expect to see services restored within the next 2 hours. We will provide updates as the work progresses. Thank you for your patience.
Posted Aug 05, 2026 - 12:17 EDT

Identified

The Town of Holly Springs has informed Ting they are preforming emergency maintenance on mainline fiber cables which have been damaged. The work area is in the vicinity of Teal Lake, Eno and Wildwood. We will provide an ETA for work to complete as soon as its available. Thanks for your patience.
Posted Aug 05, 2026 - 10:45 EDT
This incident affects: North Carolina (Holly Springs, NC).