Ting Internet - Partial Outage in Centennial CO.

Incident Report for Ting Internet

Update

Currently our team has been working on replacing the damaged fiber lines. We are currently connecting them together. Will continue to work diligently on getting the connection back up and working as quickly as possible.

Thank you for your patience as we complete the repair.
Posted Sep 15, 2025 - 19:25 EDT

Identified

A severed fiber reel has caused a service disruption affecting three domes. Our team is on-site and actively working to couple and rerun a subsection of the fiber to restore service. At this time, there is no ETR. We will share updates as they become available. Thank you for your patience.
Posted Sep 15, 2025 - 16:27 EDT

Investigating

We are currently investigating an issue affecting service for a small number of customers on E Fremont Cir S in Centennial, CO. Our field teams are en route, and we will provide updates as more information becomes available
Posted Sep 15, 2025 - 13:35 EDT
This incident affects: Colorado (Centennial, CO).