Ting Internet -Sanford, NC - Partial Outage

Incident Report for Ting Internet

Identified

Our field techs have identified the problem and are currently working on the repair. No ETA at this time.
Posted Nov 22, 2025 - 16:09 EST

Investigating

Ting Internet engineers are investigating reports of an outage impacting service for some customers in Sanford, NC. We will post further information and next steps here as soon as it becomes available.
Posted Nov 22, 2025 - 14:14 EST
This incident affects: North Carolina (Sanford, NC).