Our scheduled maintenance on the Ting Internet network in Fuquay-Varina, NC, began last night and is still ongoing. This work is necessary to move fiber connections to accommodate the Hilltop Needmore road construction project. Our work in this area has continued throughout the night and has gone longer than expected. We are continuing the work here to restore service.
We thank you for your patience. Once the maintenance is completed, your service will be automatically restored.
Posted Sep 23, 2025 - 08:51 EDT
Update
Our scheduled maintenance on the Ting Internet network in Fuquay-Varina, NC, began last night and is still ongoing. This work is necessary to move fiber connections to accommodate the Hilltop Needmore road construction project.
We thank you for your patience. Once the maintenance is completed, your service will be automatically restored.
Posted Sep 23, 2025 - 07:35 EDT
Scheduled
During the week of September 23-27, from 12:00 AM to 6:00 AM, we're planning scheduled maintenance on the Ting Internet network in Fuquay-Varina, NC to move fiber connections to accommodate the Hilltop Needmore road construction project.
Customers may experience a service disruption on one night during the maintenance window, after which their service will be automatically restored.
Posted Sep 09, 2025 - 15:26 EDT
This scheduled maintenance affected: North Carolina (Fuquay-Varina, NC).