SimplyBits Fax Services Affected

Incident Report for Ting Internet

Resolved

Fax services have been restored and customers should contact support if they are still having issues with faxing.
Posted Jun 03, 2025 - 19:08 EDT

Investigating

We are currently aware that there is a network issue affecting fax services for SimplyBits customers. We know that this issue is outside of our own infrastructure, and under the scope of our upstream provider for fax service access, and that the upstream provider has dispatched a technician to investigate. We do not yet have an ETA when this will be restored however, and will post updates here when available.
Posted Jun 03, 2025 - 13:34 EDT
This incident affected: Arizona (Tucson).