SimplyBits - Golder Ranch Tower Outage

Incident Report for Ting Internet

Identified

Our third party network partner has confirmed an outage affecting two of our towers, Golder Ranch and Catalina due to a fiber cut in the area. 79 customers are affected.
Third party technicians are working with us on restoration, but no ETR has been provided as of yet.
Posted Sep 08, 2026 - 17:55 EDT

Update

We have one of our infrastructure technicians heading out to the tower site for further investigation.
Posted Sep 08, 2026 - 16:20 EDT

Investigating

We have discovered an issue with our tower in the Catalina, AZ area (Golder Ranch). There are approximately 47 customers connected to this tower, all of which are currently offline. Our engineers are currently looking into a fix as soon as possible.
Posted Sep 08, 2026 - 15:56 EDT
This incident affects: Arizona (Tucson, Catalina, Oro Valley).