Potential outage in Centennial, Colorado

Incident Report for Ting Internet

Resolved

Looks like the issue was related to power.
Posted Sep 16, 2025 - 19:06 EDT

Investigating

We currently noticed some houses going offline within the last 15 minutes. We are currently investigating it and will post an update when more information becomes available.

Thank you for your patience.
Posted Sep 16, 2025 - 18:48 EDT
This incident affected: Colorado (Centennial, CO).