Ting.com website - credit card updates

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Jul 15, 2026 - 09:58 EDT

Identified

Ting Internet engineers are working to resolve an issue with the ting.com website and updating Credit Card information. We will provide a further update once the issue is resolved and the system is working normally.
Posted Jul 14, 2026 - 17:02 EDT
This incident affected: Ting Website, Shop & Your Account.