Ting Internet - Service Degradation in Centennial CO.

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 08:13 EDT

Monitoring

We continue to closely monitor the network to ensure there are no further issues. If you're still experiencing connectivity problems, please try rebooting your router and fiber ONT. If the issue persists, feel free to contact our support team at 1-844-846-4994 for further assistance.
Posted Oct 17, 2025 - 17:49 EDT

Investigating

We are currently investigating a service degradation that may be affecting some customers in Centennial, CO. If you are still experiencing issues, please try rebooting your router and fiber ONT. Should the problem persist, contact us at 1-844-846-4994 for further troubleshooting assistance.
Posted Oct 17, 2025 - 15:54 EDT
This incident affected: Colorado (Centennial, CO).