Ting.com Order Processing

Incident Report for Ting Internet

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 03, 2025 - 21:22 EST

Investigating

We are currently experiencing issues with our order process on ting.com. This is not current customer affecting but orders are not processing correctly on our website. We are looking into the cause and will have more info as it becomes available.
Posted Dec 03, 2025 - 15:28 EST
This incident affects: Virginia (Charlottesville, VA, Alexandria, VA), Idaho (Greater Sandpoint, ID, Ponderay, ID), Maryland (Westminster, MD), Colorado (Aspen, CO, Basalt, CO, Bayfield, CO, Carbondale, CO, Centennial, CO, Colorado Springs, CO, Cortez, CO, De Beque, CO, Dolores, CO, Durango, CO, Glenwood Springs, CO, Greenwood Village, CO, Grand Junction, CO, New Castle, CO, Parachute, CO, Rifle, CO, Silt, CO, Willits, CO, Thornton, CO), New Mexico (Farmington, NM), California (Culver City, CA, Encinitas, CA, Fullerton, CA, Solana Beach, CA, Carlsbad, CA, Laguna Woods Village), Arizona (Tucson, Catalina, Amado, Douglas, Green Valley, Marana, Mt. Lemmon, Nogales, Oracle, Oro Valley, Rio Rico, Sahuarita, San Manuel, Tubac, Vail), North Carolina (Angiers, NC, Fuquay-Varina, NC, Holly Springs, NC, Rolesville, NC, Sanford, NC, Wake Forest, NC), Tennessee (Memphis), and Customer Support, Ting Website, Shop & Your Account, Shipping & Returns.