Ting Centennial - Power outage

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Jul 26, 2026 - 18:56 EDT

Investigating

Xcel Energy indicates that the power outages are still pending investigation. We will post regular updates as they become available.
Posted Jul 26, 2026 - 17:42 EDT
This incident affected: Colorado (Centennial, CO, Colorado Springs, CO, Greenwood Village, CO).