Centennial CO Outage

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Sep 21, 2026 - 14:33 EDT

Update

Work is continuing and is roughly 25% completed at this time.
Posted Sep 21, 2026 - 11:56 EDT

Identified

4 fibers were damaged intentionally and our techs will need to send new fiber to each customer. We are hoping to accomplish this on Monday September 21 to reinstate service. We do not have an ETA at this time. We will update with an ETA when we can.
Posted Sep 20, 2026 - 21:01 EDT

Update

Our techs are still looking into the cause of this outage. We will have more updates as we get them. No ETA at this time.

Thank you for your patience.
Posted Sep 20, 2026 - 20:28 EDT

Investigating

We see a small number of customers in Centennial CO affected by an outage. Out techs are looking into the cause and we will update when we have more.
Posted Sep 20, 2026 - 17:52 EDT
This incident affected: Colorado (Centennial, CO).