Ting Internet - Partial Outage in Holly Springs, NC.

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Mar 04, 2026 - 22:01 EST

Monitoring

As of 9:22 PM, fiber repairs are complete and affected services are returning online. Our team will continue to monitor the network to ensure stability. We apologize for the disruption and appreciate your patience.
Posted Mar 04, 2026 - 21:23 EST

Update

Update (8:13 PM): While preparing for repairs, our field team discovered additional fiber damage. Consequently, the outage is affecting a larger area than initially reported. Our current estimated time for full restoration is 10:00 PM.
Posted Mar 04, 2026 - 20:15 EST

Update

We are continuing to work on a fix for this issue.
Posted Mar 04, 2026 - 20:07 EST

Identified

Update: as of 7:02 pm damage has been identified. Repair materials are being staged on-site. We appreciate your patience as we work to restore service
Posted Mar 04, 2026 - 19:03 EST

Update

as of 6:20PM, Ting internet technicians are on site in the Jasper Point Dr area and investigating damage impacting customers in the area. We will post an ETA for service restoration when available.
Posted Mar 04, 2026 - 18:24 EST

Investigating

We are currently investigating a service outage impacting some customers in the Holly Springs, NC market. Our team is working to identify the cause, and we will share updates as more information becomes available
Posted Mar 04, 2026 - 16:49 EST
This incident affected: North Carolina (Holly Springs, NC).