Partial Outage Centennial, CO

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Jun 19, 2026 - 13:33 EDT

Monitoring

Splicing is complete and service is restored. If you are still experiencing issues, please reboot your equipment. If problems persist, please call Support at 1-844-846-4994 thank you
Posted Jun 18, 2026 - 23:22 EDT

Update

Our technicians are actively performing splice work on the affected lines. Estimated time for service to be restored remains 8:30 PM MST. Thank you for your patience while we work to resolve this issue.
Posted Jun 18, 2026 - 21:59 EDT

Update

Our technicians are actively performing splice work on the affected lines. We estimate service will be restored by 8:30 PM MST. Thank you for your patience while we work to resolve this issue.
Posted Jun 18, 2026 - 20:50 EDT

Update

The replacement fiber cable is in place and fiber splicing is underway
Posted Jun 18, 2026 - 19:45 EDT

Update

Necessary repair materials have arrived on site, and our team will begin restoration work shortly.
Posted Jun 18, 2026 - 19:00 EDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 18, 2026 - 18:43 EDT

Identified

Field team located the fiber damage and is prepping materials for the repair.
Posted Jun 18, 2026 - 17:00 EDT

Update

Field team located the fiber damage and is prepping materials for the repair.
Posted Jun 18, 2026 - 16:59 EDT

Investigating

We are currently investigating this issue.
Posted Jun 18, 2026 - 15:25 EDT
This incident affected: Colorado (Centennial, CO).