The implemented fix has addressed the previous issue and all customers impacted are back online. If you are still seeing issues, please contact us for further assistance.
Posted Apr 30, 2026 - 09:01 EDT
Monitoring
Our engineers have implemented a fix and we are seeing service restored for impacted customers. Please reboot your equipment if you are still seeing issues.
Posted Apr 30, 2026 - 07:28 EDT
Update
We are currently investigating an issue with a small subset of customers after last night's maintenance. The majority of customer's, if offline, can recover after a reboot of their internet modem and their router, but others may still find themselves without service. Our engineers are currently working on a solution and we will update here once resolved.
Posted Apr 30, 2026 - 07:12 EDT
Identified
Scheduled maintenance has completed in Charlottesville, VA. If you find your service is offline, please power cycle your router (turn it off, wait 10 seconds, then turn it on again) and connectivity should be restored once the router has completed a reboot.
If not, please give us a call at 1-844-846-4994 for individual troubleshooting.
Posted Apr 30, 2026 - 06:44 EDT
This incident affected: Virginia (Charlottesville, VA).