We're happy to report all of the repair work has now been completed with service fully restored. That being said, if you're located in Wake Forest, North Carolina and you are still experiencing issues with your Ting Fiber Internet connection, please call in for Support at 1-844-846-4994 (Available 24/7) so we can assist you.
Posted Feb 18, 2025 - 20:21 EST
Update
Repair work continues here, with a revised ETR of 8:30. Nearly all services were restored briefly but further damage to a fiber buffer tube necessitated a new cut and additional re-splice. Ting techs are still working to effect full repairs.
Posted Feb 18, 2025 - 19:36 EST
Update
Repair work is now in progress on severed fiber lines. Service restoration will be piecemeal as strands are re-spliced, with a currently estimated completion time for full repair near 7:30 tonight.
Posted Feb 18, 2025 - 16:34 EST
Update
Ting technicians continue to assess the extent of the damage to our fiber lines, and while an ETR is not yet available we hope to have one soon. Information will be updated here as soon as it is available. Active work in the field is urgent and ongoing.
Posted Feb 18, 2025 - 14:39 EST
Identified
Ting Internet engineers have pinpointed a fiber break in the area affecting customers in the Averette Ridge & Jones Dairy Farm Rd areas, and are working to determine the scope of repairs. We will provide further info and an ETA as soon as possible.
Posted Feb 18, 2025 - 12:41 EST
Investigating
Ting Internet engineers are investigating reports of an outage affecting some customers in Wake Forest, NC.
We will provide further information as soon as possible.
Posted Feb 18, 2025 - 11:15 EST
This incident affected: North Carolina (Wake Forest, NC).