SimplyBits - Service Offline for Some Customers in Tucson, AZ

Incident Report for Ting Internet

Resolved

Service has been restored to the customers in the N Stone Ave area. If you are not seeing service restoration, please power cycle your Simply Bits-supplied equipment along with any routers attached. If you continue to experience trouble connecting, please reach out to our team at (520) 545-0333.
Posted Jan 18, 2026 - 19:32 EST

Investigating

We have identified a sector of our tower near N Stone Ave that is currently offline which is affecting service for some customers. We are investigating the cause of the interruption and will update as information is available.
Posted Jan 18, 2026 - 18:16 EST
This incident affected: Arizona (Tucson).