Ting Internet Holly Springs, NC Partial Outage

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Aug 04, 2026 - 08:43 EDT

Monitoring

Fiber repairs have completed and service has been restored if you are still having issues please reboot your equipment. If rebooting your equipment does not resolve the issue please call support at 1-844-846-4994
Posted Aug 03, 2026 - 19:34 EDT

Update

Restoration efforts are nearing completion, thank you for your patience as we work to resolve this issue.
Posted Aug 03, 2026 - 19:00 EDT

Identified

Our tech is onsite working on this issue at this time. So far almost have of the 20 affected customers are back online. Work continues.
Posted Aug 03, 2026 - 17:22 EDT

Investigating

Ting Internet engineers are investigating reports of an outage impacting service for some customers in Holly Springs, NC. We will post further information and next steps here as soon as it becomes available.
Posted Aug 03, 2026 - 16:14 EDT
This incident affected: North Carolina (Holly Springs, NC).