Fiber repairs have started, and service is beginning to return for some customers. We’ll notify you once full restoration is confirmed. Thanks for your patience
Posted Apr 27, 2026 - 19:42 EDT
Update
We are still working on repairing the fiber located under the road in this repair. We will continue to update with new information as it becomes available.
Thank you for your patience.
Posted Apr 27, 2026 - 18:28 EDT
Identified
Ting Engineers are working to have new fiber conduit installed and then new fiber will be placed through the conduit and spliced in to repair the damaged section.
The damage is extensive in this area and will take time to complete. We will provide an ETA once work progresses and we have a proper estimate. Thank you for your patience.
Posted Apr 27, 2026 - 15:20 EDT
Update
Ting engineers are on-site now and surveying physical damage to fiber strands in this area. No ETR is yet available while the scope of the repair is being assessed.
Posted Apr 27, 2026 - 14:08 EDT
Update
We continue to investigate the cause of this outage and have no ETA at this time.
Posted Apr 27, 2026 - 14:07 EDT
Update
Ting engineers are on-site now and surveying physical damage to fiber strands in this area. No ETR is yet available while the scope of the repair is being assessed.
Posted Apr 27, 2026 - 13:02 EDT
Investigating
We are seeing a small outage in Holly Springs at this time. Approx 30 customers affected. We are investigating the cause and will have more updates when available.
Posted Apr 27, 2026 - 12:10 EDT
This incident affects: North Carolina (Holly Springs, NC).