As of now, repairs for widespread neighborhood outages have concluded but we still have individual customers offline. Due to the spread-out nature of the ones still not working, we do not have a way to determine if individuals are offline due to power-related issues or if it is fiber damage to specific homes.
In cases where trees came down and overhead lines were damaged, we have been unable to effect repairs until the utility power company is hands-off with theirs. If you are still offline at this point but believe the power company has finished their work nearby, please get in touch at 1-844-846-4994 so your repair can be prioritized as soon as possible.
Posted Feb 18, 2025 - 16:58 EST
Update
We are actively addressing the service issues in Charlottesville, VA. Our technicians are working diligently to resolve the problem, which seems to be connected to the widespread power outages in the city. While we do not have an estimated time for restoration yet, we will keep you updated as we make progress.
Posted Feb 17, 2025 - 20:45 EST
Update
We are experiencing some issues in Charlotteville Va. Our techs are looking into this. This is very likely power related as there are numerous power issues within the city. We do not have an ETA at this time.
Posted Feb 16, 2025 - 17:03 EST
Update
We are experiencing some issues in the Jefferson Ridge area of Charlotteville Va. Our techs are looking into this. This is very likely power related as there are numerous power issues within the city. We do not have an ETA at this time.
Posted Feb 16, 2025 - 16:59 EST
Update
We are experiencing some issues in the Jefferson Ridge area of Charlottevilles Va. Our techs are looking into this. This is possibly power related. We do not have an ETA at this time.
Posted Feb 16, 2025 - 15:36 EST
Investigating
We are experiencing some issues in the Jefferson Ridge area of Charlottevilles Va. Our techs are looking into this. We do not have an ETA at this time.
Posted Feb 16, 2025 - 15:08 EST
This incident affected: Virginia (Charlottesville, VA).