We are seeing service restored to the area affected. If you are having any issues at this time, please reach out to our Support team at 1-844-846-4994.
Posted Apr 09, 2025 - 10:26 EDT
Update
The bulk of fiber repair work has been completed. We are seeing near full recovery, with a few isolated homes still offline. Work will continue to track these down, but if your service is still offline at this time please attempt a power cycle of the Ting Fiber modem (ONT) and your router to see if service recovers. If service remains offline, we may need to proceed with individual troubleshooting at 1-844-846-4994 to resolve.
Posted Apr 09, 2025 - 00:41 EDT
Update
Ting Internet Engineers continue to work on repairing the damaged fiber. As previously mentioned, the damage is quite extensive and so repairing the fiber will involve disconnecting other working fibers to be able to repair the broken fibers. As a result, customers in Holly Springs can expect potential intermittent outages over the course of this evening. We still do not have an ETA as to when ALL of the repairs will be completed, however, we will provide further updates here as they become available. We appreciate your patience.
Posted Apr 08, 2025 - 20:16 EDT
Update
Ting Internet Engineers are on site with representatives from the Town of Holly Springs at the site of the fiber cut. The damage is extensive and repairing the fiber will involve disconnecting other working fibers to be able to repair the broken fibers.
Customers in Holly Springs can expect potential intermittent outages over the course of this evening. We are unable to project an ETA at this time, but will provide updates as work progresses.
Thank you for your patience.
Posted Apr 08, 2025 - 17:49 EDT
Update
Ting Internet Engineers are on site with representatives from the Town of Holly Springs at the site of the fiber cut. Heavy equipment is required to gain access to the damaged area. We expect to provide an ETA shortly. Thank you for your patience.
Posted Apr 08, 2025 - 17:24 EDT
Identified
Ting Internet engineers are on site in Sunset Ridge North assessing the damage and determining the scope and timeframe for repair. We will provide more information as soon as possible.
Posted Apr 08, 2025 - 14:03 EDT
Investigating
Ting Internet engineers are investigating reports of an outage affecting some parts of Holly Springs, NC. We will post more information as soon as possible.
Posted Apr 08, 2025 - 13:30 EDT
This incident affected: North Carolina (Holly Springs, NC).