Ting Internet / SimplyBits - Partial Outage - Tucson, AZ

Incident Report for Ting Internet

Resolved

Our team was able to identify the issue, and repairs have been made. All customers should be back online; if not, power cycle your equipment. If you still experience the issue, please contact us at 844-846-4994 for further assistance.
Posted Jun 07, 2026 - 00:40 EDT

Investigating

We are currently investigating a partial service outage affecting customers in Tucson, AZ. Additional updates will be shared as more information becomes available.
Posted Jun 06, 2026 - 23:29 EDT
This incident affected: Arizona (Tucson).