Small outage in Holly Springs, North Carolina

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Nov 11, 2025 - 17:15 EST

Monitoring

We found the issue within the fiber lines and made the necessary repairs that everyone should now be back up and running. If you continue to have issues with service please restart your equipment and contact us if any issues persist at 1-844-846-4994.

Thank you for patience as we completed the repairs
Posted Nov 11, 2025 - 14:18 EST

Investigating

We are currently looking into a small outage impacting a handful of customers in Holly Springs, North Carolina.

Please stand by as more information becomes available.
Posted Nov 11, 2025 - 11:12 EST
This incident affected: North Carolina (Holly Springs, NC).